← Back to CVE Explorer

CVE-2025-58769

Full vulnerability record from the local CVENow database.

Description

auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.

Severity
LOW
CVSS score
3.3 (v3.1)
Vulnerability status
Deferred
Source identifier
Published
2025-10-01 20:18:38.077000
Last modified
2026-10-19 17:10:00.173000
View original CVE JSON
{
  "id": "CVE-2025-58769",
  "sourceIdentifier": "[email protected]",
  "published": "2025-10-01T20:18:38.077",
  "lastModified": "2026-10-19T17:10:00.173",
  "vulnStatus": "Deferred",
  "cveTags": [],
  "descriptions": [
    {
      "lang": "en",
      "value": "auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0."
    },
    {
      "lang": "es",
      "value": "auth0-PHP es un SDK para las APIs de Autenticación y Gestión de Auth0. En las versiones 3.3.0 a la 8.16.0, el endpoint de Importación Masiva de Usuarios en aplicaciones construidas con el SDK no valida el wrapper o el valor de la ruta del archivo. Sin una validación adecuada, las aplicaciones afectadas pueden aceptar rutas de archivo o URLs arbitrarias. La vulnerabilidad afecta a cualquier aplicación que use directamente el SDK Auth0-PHP (versiones 3.3.0-8.16.0) o dependa indirectamente de esas versiones a través de los SDKs Auth0/symfony, Auth0/laravel-auth0, o Auth0/wordpress. Este problema está corregido en la versión 8.17.0."
    }
  ],
  "affected": [
    {
      "source": "[email protected]",
      "affectedData": [
        {
          "vendor": "auth0",
          "product": "laravel-auth0",
          "versions": [
            {
              "version": ">= 3.3.0, < 8.17.0",
              "status": "affected"
            }
          ]
        }
      ]
    }
  ],
  "metrics": {
    "cvssMetricV31": [
      {
        "source": "[email protected]",
        "type": "Secondary",
        "cvssData": {
          "version": "3.1",
          "vectorString": "CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N",
          "baseScore": 3.3,
          "baseSeverity": "LOW",
          "attackVector": "NETWORK",
          "attackComplexity": "HIGH",
          "privilegesRequired": "HIGH",
          "userInteraction": "NONE",
          "scope": "UNCHANGED",
          "confidentialityImpact": "LOW",
          "integrityImpact": "LOW",
          "availabilityImpact": "NONE"
        },
        "exploitabilityScore": 0.7,
        "impactScore": 2.5
      }
    ],
    "ssvcV203": [
      {
        "source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
        "ssvcData": {
          "timestamp": "2025-10-01T20:09:35.613703Z",
          "id": "CVE-2025-58769",
          "options": [
            {
              "exploitation": "none"
            },
            {
              "automatable": "no"
            },
            {
              "technicalImpact": "partial"
            }
          ],
          "role": "CISA Coordinator",
          "version": "2.0.3"
        }
      }
    ]
  },
  "weaknesses": [
    {
      "source": "[email protected]",
      "type": "Secondary",
      "description": [
        {
          "lang": "en",
          "value": "CWE-22"
        },
        {
          "lang": "en",
          "value": "CWE-73"
        }
      ]
    }
  ],
  "references": [
    {
      "url": "https://github.com/auth0/auth0-PHP/commit/9026da58f5c381cd4cb5932de829eff6eacbb65c",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/auth0/auth0-PHP/releases/tag/8.17.0",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/auth0/auth0-PHP/security/advisories/GHSA-9mh6-g99m-ppcw",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/auth0/laravel-auth0/security/advisories/GHSA-hjfh-5jmm-xr24",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/auth0/symfony/security/advisories/GHSA-7jp2-5h22-m432",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/auth0/wordpress/security/advisories/GHSA-w22c-pw5m-482x",
      "source": "[email protected]"
    }
  ]
}