← Back to CVE Explorer

CVE-2025-61591

Full vulnerability record from the local CVENow database.

Description

Cursor is a code editor built for programming with AI. In versions 1.7 and below, when MCP uses OAuth authentication with an untrusted MCP server, an attacker can impersonate a malicious MCP server and return crafted, maliciously injected commands during the interaction process, leading to command injection and potential remote code execution. If chained with an untrusted MCP service via OAuth, this command injection vulnerability could allow arbitrary code execution on the host by the agent. This can then be used to directly compromise the system by executing malicious commands with full user privileges. This issue does not currently have a fixed release version, but there is a patch, 2025.09.17-25b418f.

Severity
HIGH
CVSS score
8.8 (v3.1)
Vulnerability status
Analyzed
Source identifier
Published
2025-10-03 17:15:47.853000
Last modified
2026-10-19 17:10:00.173000
View original CVE JSON
{
  "id": "CVE-2025-61591",
  "sourceIdentifier": "[email protected]",
  "published": "2025-10-03T17:15:47.853",
  "lastModified": "2026-10-19T17:10:00.173",
  "vulnStatus": "Analyzed",
  "cveTags": [],
  "descriptions": [
    {
      "lang": "en",
      "value": "Cursor is a code editor built for programming with AI. In versions 1.7 and below, when MCP uses OAuth authentication with an untrusted MCP server, an attacker can impersonate a malicious MCP server and return crafted, maliciously injected commands during the interaction process, leading to command injection and potential remote code execution. If chained with an untrusted MCP service via OAuth, this command injection vulnerability could allow arbitrary code execution on the host by the agent. This can then be used to directly compromise the system by executing malicious commands with full user privileges. This issue does not currently have a fixed release version, but there is a patch, 2025.09.17-25b418f."
    },
    {
      "lang": "es",
      "value": "Cursor es un editor de código construido para programar con IA. En las versiones 1.7 e inferiores, cuando MCP utiliza autenticación OAuth con un servidor MCP no confiable, un atacante puede suplantar a un servidor MCP malicioso y devolver comandos elaborados y maliciosamente inyectados durante el proceso de interacción, lo que lleva a la inyección de comandos y a una potencial ejecución remota de código. Si se encadena con un servicio MCP no confiable a través de OAuth, esta vulnerabilidad de inyección de comandos podría permitir la ejecución de código arbitrario en el host por parte del agente. Esto puede entonces ser utilizado para comprometer directamente el sistema ejecutando comandos maliciosos con privilegios de usuario completos. Este problema no tiene actualmente una versión de lanzamiento corregida, pero existe un parche, 2025.09.17-25b418f."
    }
  ],
  "affected": [
    {
      "source": "[email protected]",
      "affectedData": [
        {
          "vendor": "cursor",
          "product": "cursor",
          "versions": [
            {
              "version": "<= 1.7",
              "status": "affected"
            }
          ]
        }
      ]
    }
  ],
  "metrics": {
    "cvssMetricV31": [
      {
        "source": "[email protected]",
        "type": "Secondary",
        "cvssData": {
          "version": "3.1",
          "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H",
          "baseScore": 8.8,
          "baseSeverity": "HIGH",
          "attackVector": "NETWORK",
          "attackComplexity": "LOW",
          "privilegesRequired": "NONE",
          "userInteraction": "REQUIRED",
          "scope": "UNCHANGED",
          "confidentialityImpact": "HIGH",
          "integrityImpact": "HIGH",
          "availabilityImpact": "HIGH"
        },
        "exploitabilityScore": 2.8,
        "impactScore": 5.9
      }
    ],
    "ssvcV203": [
      {
        "source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
        "ssvcData": {
          "timestamp": "2025-10-03T18:28:25.470542Z",
          "id": "CVE-2025-61591",
          "options": [
            {
              "exploitation": "none"
            },
            {
              "automatable": "yes"
            },
            {
              "technicalImpact": "total"
            }
          ],
          "role": "CISA Coordinator",
          "version": "2.0.3"
        }
      }
    ]
  },
  "weaknesses": [
    {
      "source": "[email protected]",
      "type": "Secondary",
      "description": [
        {
          "lang": "en",
          "value": "CWE-78"
        }
      ]
    }
  ],
  "configurations": [
    {
      "nodes": [
        {
          "operator": "OR",
          "negate": false,
          "cpeMatch": [
            {
              "vulnerable": true,
              "criteria": "cpe:2.3:a:anysphere:cursor:*:*:*:*:*:*:*:*",
              "versionEndIncluding": "1.7",
              "matchCriteriaId": "4D061389-A91F-47B4-8F3F-50B343CE1A70"
            }
          ]
        }
      ]
    }
  ],
  "references": [
    {
      "url": "https://github.com/cursor/cursor/security/advisories/GHSA-wj33-264c-j9cq",
      "source": "[email protected]",
      "tags": [
        "Vendor Advisory"
      ]
    }
  ]
}