CVE-2025-62164
Full vulnerability record from the local CVENow database.
Description
vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.
View original CVE JSON
{
"id": "CVE-2025-62164",
"sourceIdentifier": "[email protected]",
"published": "2025-11-21T02:15:43.193",
"lastModified": "2026-10-19T13:10:00.110",
"vulnStatus": "Analyzed",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1."
},
{
"lang": "es",
"value": "vLLM es un motor de inferencia y servicio para modelos de lenguaje grandes (LLM). Desde las versiones 0.10.2 hasta la 0.11.1, existe una vulnerabilidad de corrupción de memoria que podría conducir a un fallo (denegación de servicio) y potencialmente a ejecución remota de código (RCE) en el endpoint de la API de Completions. Al procesar incrustaciones de prompt proporcionadas por el usuario, el endpoint carga tensores serializados utilizando torch.load() sin validación suficiente. Debido a un cambio introducido en PyTorch 2.8.0, las comprobaciones de integridad de tensores dispersos están deshabilitadas por defecto. Como resultado, los tensores creados maliciosamente pueden eludir las comprobaciones de límites internas y desencadenar una escritura de memoria fuera de límites durante la llamada a to_dense(). Esta corrupción de memoria puede provocar el fallo de vLLM y potencialmente conducir a la ejecución de código en el servidor que aloja vLLM. Este problema ha sido parcheado en la versión 0.11.1."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "vllm-project",
"product": "vllm",
"versions": [
{
"version": ">= 0.10.2, < 0.11.1",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV31": [
{
"source": "[email protected]",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H",
"baseScore": 8.8,
"baseSeverity": "HIGH",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"privilegesRequired": "LOW",
"userInteraction": "NONE",
"scope": "UNCHANGED",
"confidentialityImpact": "HIGH",
"integrityImpact": "HIGH",
"availabilityImpact": "HIGH"
},
"exploitabilityScore": 2.8,
"impactScore": 5.9
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2025-11-24T17:15:13.097938Z",
"id": "CVE-2025-62164",
"options": [
{
"exploitation": "none"
},
{
"automatable": "no"
},
{
"technicalImpact": "total"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-20"
},
{
"lang": "en",
"value": "CWE-123"
},
{
"lang": "en",
"value": "CWE-502"
},
{
"lang": "en",
"value": "CWE-787"
}
]
}
],
"configurations": [
{
"nodes": [
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*",
"versionStartIncluding": "0.10.2",
"versionEndExcluding": "0.11.1",
"matchCriteriaId": "257F44B9-5BDF-4A61-B7B9-A901DD438F9C"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:vllm:vllm:0.11.1:rc0:*:*:*:*:*:*",
"matchCriteriaId": "FEE054E1-1F84-4ACC-894C-D7E3652EF1B1"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:vllm:vllm:0.11.1:rc1:*:*:*:*:*:*",
"matchCriteriaId": "B05850DF-38FE-439F-9F7A-AA96DA9038CC"
}
]
}
]
}
],
"references": [
{
"url": "https://github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b",
"source": "[email protected]",
"tags": [
"Patch"
]
},
{
"url": "https://github.com/vllm-project/vllm/pull/27204",
"source": "[email protected]",
"tags": [
"Issue Tracking",
"Patch",
"Vendor Advisory"
]
},
{
"url": "https://github.com/vllm-project/vllm/security/advisories/GHSA-mrw7-hf4f-83pf",
"source": "[email protected]",
"tags": [
"Issue Tracking",
"Vendor Advisory"
]
}
]
}