← Back to CVE Explorer

CVE-2025-62795

Full vulnerability record from the local CVENow database.

Description

JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to v3.10.21-lts and v4.10.12-lts, a low-privileged authenticated user can invoke LDAP configuration tests and start LDAP synchronization by sending crafted messages to the /ws/ldap/ WebSocket endpoint, bypassing authorization checks and potentially exposing LDAP credentials or causing unintended sync operations. This vulnerability is fixed in v3.10.21-lts and v4.10.12-lts.

Severity
HIGH
CVSS score
7.1 (v3.1)
Vulnerability status
Analyzed
Source identifier
Published
2025-10-30 17:15:39.723000
Last modified
2026-10-19 13:10:00.110000
View original CVE JSON
{
  "id": "CVE-2025-62795",
  "sourceIdentifier": "[email protected]",
  "published": "2025-10-30T17:15:39.723",
  "lastModified": "2026-10-19T13:10:00.110",
  "vulnStatus": "Analyzed",
  "cveTags": [],
  "descriptions": [
    {
      "lang": "en",
      "value": "JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to v3.10.21-lts and v4.10.12-lts, a low-privileged authenticated user can invoke LDAP configuration tests and start LDAP synchronization by sending crafted messages to the /ws/ldap/ WebSocket endpoint, bypassing authorization checks and potentially exposing LDAP credentials or causing unintended sync operations. This vulnerability is fixed in v3.10.21-lts and v4.10.12-lts."
    },
    {
      "lang": "es",
      "value": "JumpServer es un host bastión de código abierto y un sistema de auditoría de seguridad de operación y mantenimiento. Antes de las versiones v3.10.21-lts y v4.10.12-lts, un usuario autenticado con bajos privilegios puede invocar pruebas de configuración LDAP e iniciar la sincronización LDAP enviando mensajes manipulados al endpoint WebSocket /ws/ldap/, eludiendo las comprobaciones de autorización y potencialmente exponiendo credenciales LDAP o causando operaciones de sincronización no intencionadas. Esta vulnerabilidad está corregida en las versiones v3.10.21-lts y v4.10.12-lts."
    }
  ],
  "affected": [
    {
      "source": "[email protected]",
      "affectedData": [
        {
          "vendor": "jumpserver",
          "product": "jumpserver",
          "versions": [
            {
              "version": "< 3.10.21-lts",
              "status": "affected"
            },
            {
              "version": ">= 4.0.0, < 4.10.12-lts",
              "status": "affected"
            }
          ]
        }
      ]
    }
  ],
  "metrics": {
    "cvssMetricV31": [
      {
        "source": "[email protected]",
        "type": "Secondary",
        "cvssData": {
          "version": "3.1",
          "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N",
          "baseScore": 7.1,
          "baseSeverity": "HIGH",
          "attackVector": "NETWORK",
          "attackComplexity": "LOW",
          "privilegesRequired": "LOW",
          "userInteraction": "NONE",
          "scope": "UNCHANGED",
          "confidentialityImpact": "HIGH",
          "integrityImpact": "LOW",
          "availabilityImpact": "NONE"
        },
        "exploitabilityScore": 2.8,
        "impactScore": 4.2
      }
    ],
    "ssvcV203": [
      {
        "source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
        "ssvcData": {
          "timestamp": "2025-10-31T18:37:38.995822Z",
          "id": "CVE-2025-62795",
          "options": [
            {
              "exploitation": "poc"
            },
            {
              "automatable": "no"
            },
            {
              "technicalImpact": "partial"
            }
          ],
          "role": "CISA Coordinator",
          "version": "2.0.3"
        }
      }
    ]
  },
  "weaknesses": [
    {
      "source": "[email protected]",
      "type": "Secondary",
      "description": [
        {
          "lang": "en",
          "value": "CWE-863"
        }
      ]
    }
  ],
  "configurations": [
    {
      "nodes": [
        {
          "operator": "OR",
          "negate": false,
          "cpeMatch": [
            {
              "vulnerable": true,
              "criteria": "cpe:2.3:a:fit2cloud:jumpserver:*:*:*:*:*:*:*:*",
              "versionEndExcluding": "3.10.21",
              "matchCriteriaId": "AD0D5F68-C04D-4090-B520-BC123E079B67"
            },
            {
              "vulnerable": true,
              "criteria": "cpe:2.3:a:fit2cloud:jumpserver:*:*:*:*:*:*:*:*",
              "versionStartIncluding": "4.0.0",
              "versionEndExcluding": "4.10.12",
              "matchCriteriaId": "A27A2C67-F249-4095-A9F8-20673685125B"
            }
          ]
        }
      ]
    }
  ],
  "references": [
    {
      "url": "https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7893-256g-m822",
      "source": "[email protected]",
      "tags": [
        "Exploit",
        "Vendor Advisory"
      ]
    },
    {
      "url": "https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7893-256g-m822",
      "source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
      "tags": [
        "Exploit",
        "Vendor Advisory"
      ]
    }
  ]
}