← Back to CVE Explorer

CVE-2025-65014

Full vulnerability record from the local CVENow database.

Description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.11.0, a weak password policy vulnerability was identified in the user management functionality of the LibreNMS application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as 12345678. This exposes the platform to brute-force and credential stuffing attacks. This issue has been patched in version 25.11.0.

Severity
LOW
CVSS score
3.7 (v3.1)
Vulnerability status
Analyzed
Source identifier
Published
2025-11-18 23:15:56.313000
Last modified
2026-10-19 13:10:00.110000
View original CVE JSON
{
  "id": "CVE-2025-65014",
  "sourceIdentifier": "[email protected]",
  "published": "2025-11-18T23:15:56.313",
  "lastModified": "2026-10-19T13:10:00.110",
  "vulnStatus": "Analyzed",
  "cveTags": [],
  "descriptions": [
    {
      "lang": "en",
      "value": "LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.11.0, a weak password policy vulnerability was identified in the user management functionality of the LibreNMS application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as 12345678. This exposes the platform to brute-force and credential stuffing attacks. This issue has been patched in version 25.11.0."
    },
    {
      "lang": "es",
      "value": "LibreNMS es una herramienta de monitoreo de red basada en PHP/MySQL/SNMP con descubrimiento automático. Versiones anteriores a la versión 25.11.0, se identificó una vulnerabilidad de política de contraseña débil en la funcionalidad de gestión de usuarios de la aplicación LibreNMS. Esta vulnerabilidad permite a los administradores crear cuentas con contraseñas extremadamente débiles y predecibles, como 12345678. Esto expone la plataforma a ataques de fuerza bruta y de relleno de credenciales. Este problema ha sido parcheado en la versión 25.11.0."
    }
  ],
  "affected": [
    {
      "source": "[email protected]",
      "affectedData": [
        {
          "vendor": "librenms",
          "product": "librenms",
          "versions": [
            {
              "version": "< 25.11.0",
              "status": "affected"
            }
          ]
        }
      ]
    }
  ],
  "metrics": {
    "cvssMetricV31": [
      {
        "source": "[email protected]",
        "type": "Secondary",
        "cvssData": {
          "version": "3.1",
          "vectorString": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N",
          "baseScore": 3.7,
          "baseSeverity": "LOW",
          "attackVector": "NETWORK",
          "attackComplexity": "HIGH",
          "privilegesRequired": "NONE",
          "userInteraction": "NONE",
          "scope": "UNCHANGED",
          "confidentialityImpact": "LOW",
          "integrityImpact": "NONE",
          "availabilityImpact": "NONE"
        },
        "exploitabilityScore": 2.2,
        "impactScore": 1.4
      }
    ],
    "ssvcV203": [
      {
        "source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
        "ssvcData": {
          "timestamp": "2025-11-19T14:53:12.978777Z",
          "id": "CVE-2025-65014",
          "options": [
            {
              "exploitation": "poc"
            },
            {
              "automatable": "no"
            },
            {
              "technicalImpact": "partial"
            }
          ],
          "role": "CISA Coordinator",
          "version": "2.0.3"
        }
      }
    ]
  },
  "weaknesses": [
    {
      "source": "[email protected]",
      "type": "Secondary",
      "description": [
        {
          "lang": "en",
          "value": "CWE-521"
        }
      ]
    }
  ],
  "configurations": [
    {
      "nodes": [
        {
          "operator": "OR",
          "negate": false,
          "cpeMatch": [
            {
              "vulnerable": true,
              "criteria": "cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*",
              "versionEndExcluding": "25.11.0",
              "matchCriteriaId": "BB2997C4-F47F-4823-8E14-6FBC84E84C74"
            }
          ]
        }
      ]
    }
  ],
  "references": [
    {
      "url": "https://github.com/librenms/librenms/security/advisories/GHSA-5mrf-j8v6-f45g",
      "source": "[email protected]",
      "tags": [
        "Exploit",
        "Mitigation",
        "Vendor Advisory"
      ]
    },
    {
      "url": "https://github.com/librenms/librenms/security/advisories/GHSA-5mrf-j8v6-f45g",
      "source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
      "tags": [
        "Exploit",
        "Mitigation",
        "Vendor Advisory"
      ]
    }
  ]
}