CVE-2025-65107
Full vulnerability record from the local CVENow database.
Description
Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_<PROVIDER>_CHECK.
Severity
MEDIUM
CVSS score
6.5
(v3.1)
Vulnerability status
Analyzed
Source identifier
Published
2025-11-21 22:16:33.127000
Last modified
2026-10-19 13:10:00.110000
View original CVE JSON
{
"id": "CVE-2025-65107",
"sourceIdentifier": "[email protected]",
"published": "2025-11-21T22:16:33.127",
"lastModified": "2026-10-19T13:10:00.110",
"vulnStatus": "Analyzed",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_<PROVIDER>_CHECK."
},
{
"lang": "es",
"value": "Langfuse es una plataforma de ingeniería de modelos de lenguaje grandes de código abierto. En las versiones desde la 2.95.0 hasta la 2.95.12 y desde la 3.17.0 hasta la 3.131.0, en configuraciones de proveedor de SSO sin una configuración explícita de AUTH_<PROVIDER>_CHECK, podría ocurrir una posible toma de control de cuenta si se obliga a un usuario autenticado a llamar a una URL específicamente diseñada mediante un ataque de CSRF o phishing. Este problema ha sido parcheado en las versiones 2.95.12 y 3.131.0. Una solución alternativa para este problema implica configurar AUTH_<PROVIDER>_CHECK."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "langfuse",
"product": "langfuse",
"versions": [
{
"version": ">= 2.95.0, < 2.95.12",
"status": "affected"
},
{
"version": ">= 3.17.0, < 3.131.0",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV31": [
{
"source": "[email protected]",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N",
"baseScore": 6.5,
"baseSeverity": "MEDIUM",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"privilegesRequired": "NONE",
"userInteraction": "REQUIRED",
"scope": "UNCHANGED",
"confidentialityImpact": "HIGH",
"integrityImpact": "NONE",
"availabilityImpact": "NONE"
},
"exploitabilityScore": 2.8,
"impactScore": 3.6
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2025-11-24T17:16:30.785561Z",
"id": "CVE-2025-65107",
"options": [
{
"exploitation": "none"
},
{
"automatable": "no"
},
{
"technicalImpact": "partial"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-285"
},
{
"lang": "en",
"value": "CWE-352"
}
]
}
],
"configurations": [
{
"nodes": [
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:langfuse:langfuse:*:*:*:*:*:*:*:*",
"versionStartIncluding": "2.95.0",
"versionEndExcluding": "2.95.12",
"matchCriteriaId": "EE6B4DE7-2440-4B1D-A0F2-589B93CBDA39"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:langfuse:langfuse:*:*:*:*:*:*:*:*",
"versionStartIncluding": "3.17.0",
"versionEndExcluding": "3.131.0",
"matchCriteriaId": "FD1B1F82-761E-4FF8-A66E-0CAEA7EB39E6"
}
]
}
]
}
],
"references": [
{
"url": "https://github.com/langfuse/langfuse/security/advisories/GHSA-w9pw-c549-5m6w",
"source": "[email protected]",
"tags": [
"Mitigation",
"Vendor Advisory"
]
}
]
}