← Back to CVE Explorer

CVE-2026-114612

Full vulnerability record from the local CVENow database.

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_LOGIN to be enabled, while versions after 1.91.0 are exploitable in the default configuration. This issue was fixed in LiteLLM 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2.

Severity
CRITICAL
CVSS score
9.9 (v3.1)
Vulnerability status
Awaiting Analysis
Source identifier
Published
2026-10-22 19:17:37.540000
Last modified
2026-10-23 19:42:24.553000
View original CVE JSON
{
  "id": "CVE-2026-114612",
  "sourceIdentifier": "[email protected]",
  "published": "2026-10-22T19:17:37.540",
  "lastModified": "2026-10-23T19:42:24.553",
  "vulnStatus": "Awaiting Analysis",
  "cveTags": [],
  "descriptions": [
    {
      "lang": "en",
      "value": "LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_LOGIN to be enabled, while versions after 1.91.0 are exploitable in the default configuration. This issue was fixed in LiteLLM 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2."
    }
  ],
  "affected": [
    {
      "source": "[email protected]",
      "affectedData": [
        {
          "vendor": "BerriAI",
          "product": "litellm",
          "versions": [
            {
              "version": ">= 1.87.0, < 1.100.4",
              "status": "affected"
            },
            {
              "version": ">= 1.101.0, < 1.101.3",
              "status": "affected"
            },
            {
              "version": ">= 1.102.0, < 1.102.2",
              "status": "affected"
            },
            {
              "version": ">= 1.103.0, < 1.103.1",
              "status": "affected"
            },
            {
              "version": ">= 1.104.0-rc.1, < 1.104.0-rc.2",
              "status": "affected"
            }
          ]
        }
      ]
    }
  ],
  "metrics": {
    "cvssMetricV31": [
      {
        "source": "[email protected]",
        "type": "Secondary",
        "cvssData": {
          "version": "3.1",
          "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H",
          "baseScore": 9.9,
          "baseSeverity": "CRITICAL",
          "attackVector": "NETWORK",
          "attackComplexity": "LOW",
          "privilegesRequired": "LOW",
          "userInteraction": "NONE",
          "scope": "CHANGED",
          "confidentialityImpact": "HIGH",
          "integrityImpact": "HIGH",
          "availabilityImpact": "HIGH"
        },
        "exploitabilityScore": 3.1,
        "impactScore": 6.0
      }
    ]
  },
  "weaknesses": [
    {
      "source": "[email protected]",
      "type": "Primary",
      "description": [
        {
          "lang": "en",
          "value": "CWE-269"
        },
        {
          "lang": "en",
          "value": "CWE-345"
        },
        {
          "lang": "en",
          "value": "CWE-441"
        }
      ]
    }
  ],
  "references": [
    {
      "url": "https://github.com/BerriAI/litellm/commit/1d5fdc87fed66b49e1df8cf7d708ad93249eb7d0",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/commit/9161d7f9d6073603ba61ee4aa5e2c0ef5b37a81b",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/commit/9fa1a641119dd0d4fe43e93622eae5f482ceb63f",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/commit/a80eacacee118fbed54e3d98f239d17a63fac818",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/commit/f7cd90f09e9716652b38daec9f0640cdf49d582b",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/releases/tag/v1.100.4",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/releases/tag/v1.101.3",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/releases/tag/v1.102.2",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/releases/tag/v1.103.1",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/releases/tag/v1.104.0-rc.2",
      "source": "[email protected]"
    },
    {
      "url": "https://github.com/BerriAI/litellm/security/advisories/GHSA-7hp6-4w63-5g45",
      "source": "[email protected]"
    }
  ]
}