CVE-2026-15810
Full vulnerability record from the local CVENow database.
Description
A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.
Severity
HIGH
CVSS score
8.7
(v4.0)
Vulnerability status
Awaiting Analysis
Source identifier
f45cbf4e-4146-4068-b7e1-655ffc2c548c
Published
2026-07-24 12:16:47.543000
Last modified
2026-10-24 13:10:00.147000
View original CVE JSON
{
"id": "CVE-2026-15810",
"sourceIdentifier": "f45cbf4e-4146-4068-b7e1-655ffc2c548c",
"published": "2026-07-24T12:16:47.543",
"lastModified": "2026-10-24T13:10:00.147",
"vulnStatus": "Awaiting Analysis",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL.\n\n\nLooker-hosted and Self-hosted were found to be vulnerable.\nThis issue has already been mitigated for Looker-hosted instances. No user action is required for these.\n\n\nSelf-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+."
},
{
"lang": "es",
"value": "Una vulnerabilidad de cross-site scripting (XSS) en versiones de Google Cloud Looker anteriores a 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, y 26.8.7 en instancias alojadas por Looker y autoalojadas permite a un atacante ejecutar JavaScript arbitrario, lo que lleva a la toma de control de la cuenta administrativa utilizando una URL creada maliciosamente.\n\nSe descubrió que las instancias alojadas por Looker y autoalojadas eran vulnerables.\nEste problema ya ha sido mitigado para las instancias alojadas por Looker. No se requiere ninguna acción del usuario para estas.\n\nLas instancias autoalojadas deben ser actualizadas a las versiones parcheadas: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, o 26.8.7+."
}
],
"affected": [
{
"source": "f45cbf4e-4146-4068-b7e1-655ffc2c548c",
"affectedData": [
{
"vendor": "Google Cloud",
"product": "Looker",
"defaultStatus": "unaffected",
"platforms": [
"Looker-hosted"
],
"versions": [
{
"version": "0",
"lessThan": "25.6.103",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "25.12.65",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "25.18.68",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.0.66",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.2.47",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.4.36",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.6.28",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.8.7",
"versionType": "custom",
"status": "affected"
}
]
},
{
"vendor": "Google Cloud",
"product": "Looker",
"defaultStatus": "unaffected",
"platforms": [
"Self-hosted"
],
"versions": [
{
"version": "0",
"lessThan": "25.6.103",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "25.12.65",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "25.18.68",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.0.66",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.2.47",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.4.36",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.6.28",
"versionType": "custom",
"status": "affected"
},
{
"version": "0",
"lessThan": "26.8.7",
"versionType": "custom",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV40": [
{
"source": "f45cbf4e-4146-4068-b7e1-655ffc2c548c",
"type": "Secondary",
"cvssData": {
"version": "4.0",
"vectorString": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Amber",
"baseScore": 8.7,
"baseSeverity": "HIGH",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"attackRequirements": "NONE",
"privilegesRequired": "NONE",
"userInteraction": "PASSIVE",
"vulnConfidentialityImpact": "HIGH",
"vulnIntegrityImpact": "HIGH",
"vulnAvailabilityImpact": "HIGH",
"subConfidentialityImpact": "LOW",
"subIntegrityImpact": "LOW",
"subAvailabilityImpact": "LOW",
"exploitMaturity": "NOT_DEFINED",
"confidentialityRequirement": "NOT_DEFINED",
"integrityRequirement": "NOT_DEFINED",
"availabilityRequirement": "NOT_DEFINED",
"modifiedAttackVector": "NOT_DEFINED",
"modifiedAttackComplexity": "NOT_DEFINED",
"modifiedAttackRequirements": "NOT_DEFINED",
"modifiedPrivilegesRequired": "NOT_DEFINED",
"modifiedUserInteraction": "NOT_DEFINED",
"modifiedVulnConfidentialityImpact": "NOT_DEFINED",
"modifiedVulnIntegrityImpact": "NOT_DEFINED",
"modifiedVulnAvailabilityImpact": "NOT_DEFINED",
"modifiedSubConfidentialityImpact": "NOT_DEFINED",
"modifiedSubIntegrityImpact": "NOT_DEFINED",
"modifiedSubAvailabilityImpact": "NOT_DEFINED",
"Safety": "NOT_DEFINED",
"Automatable": "NOT_DEFINED",
"Recovery": "NOT_DEFINED",
"valueDensity": "NOT_DEFINED",
"vulnerabilityResponseEffort": "NOT_DEFINED",
"providerUrgency": "AMBER"
}
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-07-24T12:34:58.605430Z",
"id": "CVE-2026-15810",
"options": [
{
"exploitation": "none"
},
{
"automatable": "no"
},
{
"technicalImpact": "total"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "f45cbf4e-4146-4068-b7e1-655ffc2c548c",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-79"
}
]
}
],
"references": [
{
"url": "https://docs.cloud.google.com/looker/docs/release-notes#July_22_2026",
"source": "f45cbf4e-4146-4068-b7e1-655ffc2c548c"
},
{
"url": "https://docs.cloud.google.com/support/bulletins#gcp-2026-049",
"source": "f45cbf4e-4146-4068-b7e1-655ffc2c548c"
}
]
}