CVE-2026-40046
Full vulnerability record from the local CVENow database.
Description
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.
Severity
HIGH
CVSS score
7.5
(v3.1)
Vulnerability status
Awaiting Analysis
Source identifier
Published
2026-04-09 17:16:31.650000
Last modified
2026-10-26 00:10:00.150000
View original CVE JSON
{
"id": "CVE-2026-40046",
"sourceIdentifier": "[email protected]",
"published": "2026-04-09T17:16:31.650",
"lastModified": "2026-10-26T00:10:00.150",
"vulnStatus": "Awaiting Analysis",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT.\n\nThe fix for \"CVE-2025-66168: MQTT control packet remaining length field is not properly validated\" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions.\n\n\nThis issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4.\n\n\n\nUsers are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue."
},
{
"lang": "es",
"value": "Desbordamiento de entero o desbordamiento circular vulnerabilidad en Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT.\n\nLa solución para ’CVE-2025-66168: el campo de longitud restante del paquete de control MQTT no se valida correctamente’ solo se aplicó a las versiones 5.19.2 (y futuras 5.19.x) pero se omitió para todas las versiones 6.0.0+.\n\nEste problema afecta a Apache ActiveMQ: desde 6.0.0 antes de 6.2.4; Apache ActiveMQ All: desde 6.0.0 antes de 6.2.4; Apache ActiveMQ MQTT: desde 6.0.0 antes de 6.2.4.\n\nSe recomienda a los usuarios actualizar a la versión 6.2.4 o a una versión 5.19.x a partir de 5.19.2 o posterior (actualmente la última es 5.19.5), lo que soluciona el problema."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "Apache Software Foundation",
"product": "Apache ActiveMQ",
"defaultStatus": "unaffected",
"collectionURL": "https://repo.maven.apache.org/maven2",
"packageName": "org.apache.activemq:apache-activemq",
"versions": [
{
"version": "6.0.0",
"lessThan": "6.2.4",
"versionType": "semver",
"status": "affected"
}
]
},
{
"vendor": "Apache Software Foundation",
"product": "Apache ActiveMQ All",
"defaultStatus": "unaffected",
"collectionURL": "https://repo.maven.apache.org/maven2",
"packageName": "org.apache.activemq:activemq-all",
"versions": [
{
"version": "6.0.0",
"lessThan": "6.2.4",
"versionType": "semver",
"status": "affected"
}
]
},
{
"vendor": "Apache Software Foundation",
"product": "Apache ActiveMQ MQTT",
"defaultStatus": "unaffected",
"collectionURL": "https://repo.maven.apache.org/maven2",
"packageName": "org.apache.activemq:activemq-mqtt",
"versions": [
{
"version": "6.0.0",
"lessThan": "6.2.4",
"versionType": "semver",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV31": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H",
"baseScore": 7.5,
"baseSeverity": "HIGH",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"privilegesRequired": "NONE",
"userInteraction": "NONE",
"scope": "UNCHANGED",
"confidentialityImpact": "NONE",
"integrityImpact": "NONE",
"availabilityImpact": "HIGH"
},
"exploitabilityScore": 3.9,
"impactScore": 3.6
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-04-10T19:39:38.679321Z",
"id": "CVE-2026-40046",
"options": [
{
"exploitation": "none"
},
{
"automatable": "yes"
},
{
"technicalImpact": "partial"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-190"
}
]
}
],
"references": [
{
"url": "https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt",
"source": "[email protected]"
},
{
"url": "https://lists.apache.org/thread/zdntj5rcgjjzrpow84o339lzldy68zrg",
"source": "[email protected]"
},
{
"url": "https://www.cve.org/CVERecord?id=CVE-2025-66168",
"source": "[email protected]"
}
]
}