CVE-2026-42334
Full vulnerability record from the local CVENow database.
Description
Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.
View original CVE JSON
{
"id": "CVE-2026-42334",
"sourceIdentifier": "[email protected]",
"published": "2026-05-14T18:16:47.747",
"lastModified": "2026-10-26T14:10:00.130",
"vulnStatus": "Analyzed",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6."
},
{
"lang": "es",
"value": "Mongoose es una herramienta de modelado de objetos de MongoDB diseñada para funcionar en un entorno asíncrono. Antes de las versiones 6.13.9, 7.8.9, 8.22.1 y 9.1.6, una vulnerabilidad permite eludir el mecanismo de saneamiento de consultas sanitizeFilter de Mongoose a través del operador $nor. Cuando sanitizeFilter está habilitado, Mongoose envuelve los operadores de consulta en $eq para neutralizarlos. Sin embargo, antes de la corrección, $nor no estaba incluido en el conjunto de operadores lógicos que son saneados recursivamente. Debido a que $nor acepta un array (como $and y $or), y los arrays no activan hasDollarKeys(), operadores maliciosos como $ne, $gt o $regex podrían ser inyectados dentro de una cláusula $nor sin ser saneados. Esta vulnerabilidad está corregida en las versiones 6.13.9, 7.8.9, 8.22.1 y 9.1.6."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "Automattic",
"product": "mongoose",
"versions": [
{
"version": "< 6.13.9",
"status": "affected"
},
{
"version": ">= 7.0.0, <= 7.8.8",
"status": "affected"
},
{
"version": ">= 8.0.0, <= 8.22.0",
"status": "affected"
},
{
"version": ">= 9.0.0, <= 9.1.5",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV31": [
{
"source": "[email protected]",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N",
"baseScore": 7.5,
"baseSeverity": "HIGH",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"privilegesRequired": "NONE",
"userInteraction": "NONE",
"scope": "UNCHANGED",
"confidentialityImpact": "HIGH",
"integrityImpact": "NONE",
"availabilityImpact": "NONE"
},
"exploitabilityScore": 3.9,
"impactScore": 3.6
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-05-14T18:17:58.426797Z",
"id": "CVE-2026-42334",
"options": [
{
"exploitation": "none"
},
{
"automatable": "yes"
},
{
"technicalImpact": "partial"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-74"
}
]
}
],
"configurations": [
{
"nodes": [
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:*",
"versionEndExcluding": "6.13.9",
"matchCriteriaId": "CBB0B526-FA31-4FBF-B978-BFF89CD1C4F8"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:*",
"versionStartIncluding": "7.0.0",
"versionEndExcluding": "7.8.9",
"matchCriteriaId": "3B4DE619-C57D-47BF-8C59-7426C057D9E5"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:*",
"versionStartIncluding": "8.0.0",
"versionEndExcluding": "8.22.1",
"matchCriteriaId": "CFC38AA7-F763-4259-B609-07C374E94A10"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:mongoosejs:mongoose:*:*:*:*:*:node.js:*:*",
"versionStartIncluding": "9.0.0",
"versionEndExcluding": "9.1.6",
"matchCriteriaId": "A849EB68-502F-4B87-B7D9-5021F2F17D5C"
}
]
}
]
}
],
"references": [
{
"url": "https://github.com/Automattic/mongoose/security/advisories/GHSA-wpg9-53fq-2r8h",
"source": "[email protected]",
"tags": [
"Mitigation",
"Vendor Advisory"
]
}
]
}