← Back to CVE Explorer

CVE-2026-44576

Full vulnerability record from the local CVENow database.

Description

Next.js is a React framework for building full-stack web applications. From 14.2.0 to before 15.5.16 and 16.2.5, applications using React Server Components can be vulnerable to cache poisoning when shared caches do not correctly partition response variants. Under affected conditions, an attacker can cause an RSC response to be served from the original URL and poison shared cache entries so later visitors receive component payloads instead of the expected HTML. This vulnerability is fixed in 15.5.16 and 16.2.5.

Severity
MEDIUM
CVSS score
5.4 (v3.1)
Vulnerability status
Analyzed
Source identifier
Published
2026-05-13 17:16:23.040000
Last modified
2026-10-26 17:10:03.270000
View original CVE JSON
{
  "id": "CVE-2026-44576",
  "sourceIdentifier": "[email protected]",
  "published": "2026-05-13T17:16:23.040",
  "lastModified": "2026-10-26T17:10:03.270",
  "vulnStatus": "Analyzed",
  "cveTags": [],
  "descriptions": [
    {
      "lang": "en",
      "value": "Next.js is a React framework for building full-stack web applications. From 14.2.0 to before 15.5.16 and 16.2.5, applications using React Server Components can be vulnerable to cache poisoning when shared caches do not correctly partition response variants. Under affected conditions, an attacker can cause an RSC response to be served from the original URL and poison shared cache entries so later visitors receive component payloads instead of the expected HTML. This vulnerability is fixed in 15.5.16 and 16.2.5."
    },
    {
      "lang": "es",
      "value": "Next.js es un framework de React para construir aplicaciones web full-stack. Desde la versión 14.2.0 hasta antes de la 15.5.16 y la 16.2.5, las aplicaciones que utilizan React Server Components pueden ser vulnerables al envenenamiento de caché cuando las cachés compartidas no particionan correctamente las variantes de respuesta. Bajo las condiciones afectadas, un atacante puede hacer que una respuesta RSC se sirva desde la URL original y envenenar las entradas de la caché compartida para que visitantes posteriores reciban cargas útiles de componentes en lugar del HTML esperado. Esta vulnerabilidad está corregida en las versiones 15.5.16 y 16.2.5."
    }
  ],
  "affected": [
    {
      "source": "[email protected]",
      "affectedData": [
        {
          "vendor": "vercel",
          "product": "next.js",
          "versions": [
            {
              "version": ">= 14.2.0, < 15.5.16",
              "status": "affected"
            },
            {
              "version": ">= 16.0.0, < 16.2.5",
              "status": "affected"
            }
          ]
        }
      ]
    }
  ],
  "metrics": {
    "cvssMetricV31": [
      {
        "source": "[email protected]",
        "type": "Secondary",
        "cvssData": {
          "version": "3.1",
          "vectorString": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:L",
          "baseScore": 5.4,
          "baseSeverity": "MEDIUM",
          "attackVector": "NETWORK",
          "attackComplexity": "HIGH",
          "privilegesRequired": "NONE",
          "userInteraction": "NONE",
          "scope": "CHANGED",
          "confidentialityImpact": "NONE",
          "integrityImpact": "LOW",
          "availabilityImpact": "LOW"
        },
        "exploitabilityScore": 2.2,
        "impactScore": 2.7
      }
    ],
    "ssvcV203": [
      {
        "source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
        "ssvcData": {
          "timestamp": "2026-05-18T13:45:23.886970Z",
          "id": "CVE-2026-44576",
          "options": [
            {
              "exploitation": "none"
            },
            {
              "automatable": "no"
            },
            {
              "technicalImpact": "partial"
            }
          ],
          "role": "CISA Coordinator",
          "version": "2.0.3"
        }
      }
    ]
  },
  "weaknesses": [
    {
      "source": "[email protected]",
      "type": "Secondary",
      "description": [
        {
          "lang": "en",
          "value": "CWE-436"
        }
      ]
    }
  ],
  "configurations": [
    {
      "nodes": [
        {
          "operator": "OR",
          "negate": false,
          "cpeMatch": [
            {
              "vulnerable": true,
              "criteria": "cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*",
              "versionStartIncluding": "14.2.0",
              "versionEndExcluding": "15.5.16",
              "matchCriteriaId": "F402B839-26EF-4506-BF6F-038CBE1C908C"
            },
            {
              "vulnerable": true,
              "criteria": "cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*",
              "versionStartIncluding": "16.0.0",
              "versionEndExcluding": "16.2.5",
              "matchCriteriaId": "27C5CF7A-7A33-4BE4-B8FD-10BFD813204A"
            }
          ]
        }
      ]
    }
  ],
  "references": [
    {
      "url": "https://github.com/vercel/next.js/security/advisories/GHSA-wfc6-r584-vfw7",
      "source": "[email protected]",
      "tags": [
        "Vendor Advisory"
      ]
    }
  ]
}