CVE-2026-47137
Full vulnerability record from the local CVENow database.
Description
vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, the fix for GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introduced a check in nodevm.js line 263 that blocks the combination nesting: true + require: false. However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely. When require is not specified, options.require is undefined, not false. The strict equality check fails, so the security guard is skipped. Immediately after (line 280), the destructuring default require: requireOpts = false assigns requireOpts = false, producing the exact configuration the patch was designed to prevent. This issue has been patched in version 3.11.4.
View original CVE JSON
{
"id": "CVE-2026-47137",
"sourceIdentifier": "[email protected]",
"published": "2026-06-12T15:16:28.137",
"lastModified": "2026-10-26T11:10:00.157",
"vulnStatus": "Deferred",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, the fix for GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introduced a check in nodevm.js line 263 that blocks the combination nesting: true + require: false. However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely. When require is not specified, options.require is undefined, not false. The strict equality check fails, so the security guard is skipped. Immediately after (line 280), the destructuring default require: requireOpts = false assigns requireOpts = false, producing the exact configuration the patch was designed to prevent. This issue has been patched in version 3.11.4."
},
{
"lang": "es",
"value": "vm2 es una vm/sandbox de código abierto para Node.js. Antes de la versión 3.11.4, la corrección para GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introdujo una comprobación en la línea 263 de nodevm.js que bloquea la combinación nesting: true + require: false. Sin embargo, la comprobación utiliza igualdad estricta (options.require === false), lo que se elude trivialmente omitiendo por completo la opción require. Cuando require no se especifica, options.require es undefined, no false. La comprobación de igualdad estricta falla, por lo que se omite la protección de seguridad. Inmediatamente después (línea 280), la desestructuración predeterminada require: requireOpts = false asigna requireOpts = false, produciendo la configuración exacta que el parche estaba diseñado para prevenir. Este problema ha sido parcheado en la versión 3.11.4."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "patriksimek",
"product": "vm2",
"versions": [
{
"version": "< 3.11.4",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV31": [
{
"source": "[email protected]",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H",
"baseScore": 10.0,
"baseSeverity": "CRITICAL",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"privilegesRequired": "NONE",
"userInteraction": "NONE",
"scope": "CHANGED",
"confidentialityImpact": "HIGH",
"integrityImpact": "HIGH",
"availabilityImpact": "HIGH"
},
"exploitabilityScore": 3.9,
"impactScore": 6.0
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-06-12T00:00:00+00:00",
"id": "CVE-2026-47137",
"options": [
{
"exploitation": "poc"
},
{
"automatable": "yes"
},
{
"technicalImpact": "total"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-913"
}
]
}
],
"references": [
{
"url": "https://github.com/advisories/GHSA-g644-9gfx-q4q4",
"source": "[email protected]"
},
{
"url": "https://github.com/patriksimek/vm2/commit/01a7552add345d5a6862623884e6b79a85bf0568",
"source": "[email protected]"
},
{
"url": "https://github.com/patriksimek/vm2/commit/86ab819f202c3a8dad88cef5705f2e416c5188d7",
"source": "[email protected]"
},
{
"url": "https://github.com/patriksimek/vm2/releases/tag/v3.11.4",
"source": "[email protected]"
},
{
"url": "https://github.com/patriksimek/vm2/security/advisories/GHSA-m4wx-m65x-ghrr",
"source": "[email protected]"
}
]
}