CVE-2026-48047
Full vulnerability record from the local CVENow database.
Description
XWiki Platform WebJars API is a package for XWiki, a generic wiki platform. Starting with version 9.6-rc-1 and prior to versions 16.10.17, 17.4.9, and 17.10.3, a potential path traversal vulnerability allow an attacker who manages to get a malicious WebJar extension installed on the wiki to write arbitrary files. While the consequences could be severe like overriding configuration files and setting the superadmin password, the attack first requires that the attacker already has admin access to at least a subwiki to be able to install a malicious extension. Further, the attacker needs to publish a malicious extension in an extension repository that is configured in the instance. This vulnerability has been patched in XWiki 16.10.17, 17.4.9, 17.10.3, and 18.0.0RC1. XWiki is not aware of any workarounds except for being careful whom developers grant script and admin rights to.
View original CVE JSON
{
"id": "CVE-2026-48047",
"sourceIdentifier": "[email protected]",
"published": "2026-08-07T23:17:03.960",
"lastModified": "2026-10-23T20:10:00.160",
"vulnStatus": "Deferred",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "XWiki Platform WebJars API is a package for XWiki, a generic wiki platform. Starting with version 9.6-rc-1 and prior to versions 16.10.17, 17.4.9, and 17.10.3, a potential path traversal vulnerability allow an attacker who manages to get a malicious WebJar extension installed on the wiki to write arbitrary files. While the consequences could be severe like overriding configuration files and setting the superadmin password, the attack first requires that the attacker already has admin access to at least a subwiki to be able to install a malicious extension. Further, the attacker needs to publish a malicious extension in an extension repository that is configured in the instance. This vulnerability has been patched in XWiki 16.10.17, 17.4.9, 17.10.3, and 18.0.0RC1. XWiki is not aware of any workarounds except for being careful whom developers grant script and admin rights to."
},
{
"lang": "es",
"value": "La API de WebJars de la Plataforma XWiki es un paquete para XWiki, una plataforma wiki genérica. A partir de la versión 9.6-rc-1 y antes de las versiones 16.10.17, 17.4.9 y 17.10.3, una potencial vulnerabilidad de salto de ruta permite a un atacante que logra instalar una extensión WebJar maliciosa en el wiki escribir archivos arbitrarios. Si bien las consecuencias podrían ser graves, como sobrescribir archivos de configuración y establecer la contraseña de superadministrador, el ataque primero requiere que el atacante ya tenga acceso de administrador a al menos un subwiki para poder instalar una extensión maliciosa. Además, el atacante necesita publicar una extensión maliciosa en un repositorio de extensiones que esté configurado en la instancia. Esta vulnerabilidad ha sido parcheada en XWiki 16.10.17, 17.4.9, 17.10.3 y 18.0.0RC1. XWiki no tiene conocimiento de ninguna solución alternativa, excepto tener cuidado a quién los desarrolladores otorgan derechos de script y administrador."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "xwiki",
"product": "xwiki-platform",
"versions": [
{
"version": ">= 9.6-rc-1, < 16.10.17",
"status": "affected"
},
{
"version": ">= 17.0.0-rc-1, < 17.4.9",
"status": "affected"
},
{
"version": ">= 17.5.0-rc-1, < 17.10.3",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV40": [
{
"source": "[email protected]",
"type": "Secondary",
"cvssData": {
"version": "4.0",
"vectorString": "CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X",
"baseScore": 5.9,
"baseSeverity": "MEDIUM",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"attackRequirements": "PRESENT",
"privilegesRequired": "HIGH",
"userInteraction": "NONE",
"vulnConfidentialityImpact": "LOW",
"vulnIntegrityImpact": "HIGH",
"vulnAvailabilityImpact": "LOW",
"subConfidentialityImpact": "NONE",
"subIntegrityImpact": "NONE",
"subAvailabilityImpact": "NONE",
"exploitMaturity": "NOT_DEFINED",
"confidentialityRequirement": "NOT_DEFINED",
"integrityRequirement": "NOT_DEFINED",
"availabilityRequirement": "NOT_DEFINED",
"modifiedAttackVector": "NOT_DEFINED",
"modifiedAttackComplexity": "NOT_DEFINED",
"modifiedAttackRequirements": "NOT_DEFINED",
"modifiedPrivilegesRequired": "NOT_DEFINED",
"modifiedUserInteraction": "NOT_DEFINED",
"modifiedVulnConfidentialityImpact": "NOT_DEFINED",
"modifiedVulnIntegrityImpact": "NOT_DEFINED",
"modifiedVulnAvailabilityImpact": "NOT_DEFINED",
"modifiedSubConfidentialityImpact": "NOT_DEFINED",
"modifiedSubIntegrityImpact": "NOT_DEFINED",
"modifiedSubAvailabilityImpact": "NOT_DEFINED",
"Safety": "NOT_DEFINED",
"Automatable": "NOT_DEFINED",
"Recovery": "NOT_DEFINED",
"valueDensity": "NOT_DEFINED",
"vulnerabilityResponseEffort": "NOT_DEFINED",
"providerUrgency": "NOT_DEFINED"
}
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-08-10T13:34:52.530646Z",
"id": "CVE-2026-48047",
"options": [
{
"exploitation": "poc"
},
{
"automatable": "no"
},
{
"technicalImpact": "partial"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-24"
}
]
}
],
"references": [
{
"url": "https://github.com/xwiki/xwiki-platform/commit/9f747fcd3200259a1de51957d3f5f6acc8e3816c",
"source": "[email protected]"
},
{
"url": "https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-vgwr-23fq-pr7g",
"source": "[email protected]"
},
{
"url": "https://jira.xwiki.org/browse/XWIKI-23902",
"source": "[email protected]"
},
{
"url": "https://jira.xwiki.org/browse/XWIKI-23902",
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0"
}
]
}