CVE-2026-53421
Full vulnerability record from the local CVENow database.
Description
Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements can achieve remote code execution through the connector subsystem by relying on scripted connectors' (REST and SQL) capability to run Groovy scripts. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by hardening the Groovy security sandbox.
Severity
CRITICAL
CVSS score
9.8
(v3.1)
Vulnerability status
Analyzed
Source identifier
Published
2026-07-20 15:16:43.117000
Last modified
2026-10-24 20:10:00.137000
View original CVE JSON
{
"id": "CVE-2026-53421",
"sourceIdentifier": "[email protected]",
"published": "2026-07-20T15:16:43.117",
"lastModified": "2026-10-24T20:10:00.137",
"vulnStatus": "Analyzed",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "Improper Isolation or Compartmentalization vulnerability in Apache Syncope.\n\n\n\nAn administrator with adequate entitlements can achieve remote code execution through the connector subsystem by relying on scripted connectors' (REST and SQL) capability to run Groovy scripts.\n\nThis issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1.\n\n\n\n\nUsers are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by hardening the Groovy security sandbox."
},
{
"lang": "es",
"value": "Vulnerabilidad de aislamiento o compartimentación inadecuados en Apache Syncope.\n\nUn administrador con los permisos adecuados puede lograr la ejecución remota de código a través del subsistema de conectores al aprovechar la capacidad de los conectores con scripts (REST y SQL) para ejecutar scripts Groovy.\n\nEste problema afecta a Apache Syncope: desde 3.0.0-M0 hasta 3.0.16, desde 4.0.0-M0 hasta 4.0.6, desde 4.1.0-M0 hasta 4.1.1.\n\nSe recomienda a los usuarios actualizar a la versión 4.0.7 / 4.1.2, que solucionan este problema al fortalecer la sandbox de seguridad de Groovy."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "Apache Software Foundation",
"product": "Apache Syncope",
"defaultStatus": "unaffected",
"versions": [
{
"version": "3.0.0-M0",
"lessThanOrEqual": "3.0.16",
"versionType": "semver",
"status": "affected"
},
{
"version": "4.0.0-M0",
"lessThanOrEqual": "4.0.6",
"versionType": "semver",
"status": "affected"
},
{
"version": "4.1.0-M0",
"lessThanOrEqual": "4.1.1",
"versionType": "semver",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV31": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H",
"baseScore": 9.8,
"baseSeverity": "CRITICAL",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"privilegesRequired": "NONE",
"userInteraction": "NONE",
"scope": "UNCHANGED",
"confidentialityImpact": "HIGH",
"integrityImpact": "HIGH",
"availabilityImpact": "HIGH"
},
"exploitabilityScore": 3.9,
"impactScore": 5.9
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-07-21T14:36:15.555696Z",
"id": "CVE-2026-53421",
"options": [
{
"exploitation": "none"
},
{
"automatable": "yes"
},
{
"technicalImpact": "total"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-653"
}
]
}
],
"configurations": [
{
"nodes": [
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*",
"versionStartIncluding": "3.0.0",
"versionEndIncluding": "3.0.16",
"matchCriteriaId": "81A43F1F-85A5-405B-B28A-CA2AE38D5454"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*",
"versionStartIncluding": "4.0.0",
"versionEndExcluding": "4.0.7",
"matchCriteriaId": "02A0BB79-9446-40A4-B03C-2316741BB78F"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*",
"versionStartIncluding": "4.1.0",
"versionEndExcluding": "4.1.2",
"matchCriteriaId": "000C1E11-62E0-4321-8648-BB7513E8E318"
}
]
}
]
}
],
"references": [
{
"url": "https://lists.apache.org/thread/nmzvz6gb2ldm30wvyk613r8dfrb6r8yx",
"source": "[email protected]",
"tags": [
"Mailing List",
"Vendor Advisory"
]
},
{
"url": "http://www.openwall.com/lists/oss-security/2026/07/20/7",
"source": "af854a3a-2127-422b-91ae-364da2661108",
"tags": [
"Mailing List",
"Third Party Advisory"
]
}
]
}