CVE-2026-55956
Full vulnerability record from the local CVENow database.
Description
Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
Severity
MEDIUM
CVSS score
6.5
(v3.1)
Vulnerability status
Analyzed
Source identifier
Published
2026-06-29 21:16:45.597000
Last modified
2026-10-25 21:10:00.770000
View original CVE JSON
{
"id": "CVE-2026-55956",
"sourceIdentifier": "[email protected]",
"published": "2026-06-29T21:16:45.597",
"lastModified": "2026-10-25T21:10:00.770",
"vulnStatus": "Analyzed",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected.\n\nUsers are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue."
},
{
"lang": "es",
"value": "Vulnerabilidad de autorización incorrecta en Apache Tomcat conduce a que las restricciones de seguridad especificadas para el servlet predeterminado ignoren cualquier método u omisión de método configurado como parte de la restricción.\n\nEste problema afecta a Apache Tomcat: desde 11.0.0-M1 hasta 11.0.22, desde 10.1.0-M1 hasta 10.1.55, desde 9.0.0.M1 hasta 9.0.118, desde 8.5.0 hasta 8.5.100, desde 7.0.0 hasta 7.0.109. Otras versiones que han llegado al fin de su soporte también pueden verse afectadas.\n\nSe recomienda a los usuarios actualizar a la versión 11.0.23, 10.1.56 o 9.0.119, que solucionan el problema."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "Apache Software Foundation",
"product": "Apache Tomcat",
"defaultStatus": "unaffected",
"versions": [
{
"version": "11.0.0-M1",
"lessThanOrEqual": "11.0.22",
"versionType": "semver",
"status": "affected"
},
{
"version": "10.1.0-M1",
"lessThanOrEqual": "10.1.55",
"versionType": "semver",
"status": "affected"
},
{
"version": "9.0.0.M1",
"lessThanOrEqual": "9.0.118",
"versionType": "semver",
"status": "affected"
},
{
"version": "8.5.0",
"lessThanOrEqual": "8.5.100",
"versionType": "semver",
"status": "affected"
},
{
"version": "7.0.0",
"lessThanOrEqual": "7.0.109",
"versionType": "semver",
"status": "affected"
},
{
"version": "0",
"lessThan": "7.0.0",
"versionType": "semver",
"status": "unknown"
}
]
}
]
}
],
"metrics": {
"cvssMetricV31": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N",
"baseScore": 6.5,
"baseSeverity": "MEDIUM",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"privilegesRequired": "NONE",
"userInteraction": "NONE",
"scope": "UNCHANGED",
"confidentialityImpact": "LOW",
"integrityImpact": "LOW",
"availabilityImpact": "NONE"
},
"exploitabilityScore": 3.9,
"impactScore": 2.5
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-06-30T13:23:02.427983Z",
"id": "CVE-2026-55956",
"options": [
{
"exploitation": "none"
},
{
"automatable": "yes"
},
{
"technicalImpact": "partial"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-285"
}
]
}
],
"configurations": [
{
"nodes": [
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"versionEndExcluding": "9.0.119",
"matchCriteriaId": "5BB3B349-8AB6-4C07-B186-888CAFB1609E"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"versionStartIncluding": "10.1.0",
"versionEndExcluding": "10.1.56",
"matchCriteriaId": "4A8C20B4-DBE1-4890-AD5E-D5EABB6B739D"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"versionStartIncluding": "11.0.0",
"versionEndExcluding": "11.0.23",
"matchCriteriaId": "C43AD2A0-8785-4A37-AAAE-347B1E0463F1"
}
]
}
]
}
],
"references": [
{
"url": "https://lists.apache.org/thread/dcjdcnnnww9hhdm016hr0l7hpw1bzjfp",
"source": "[email protected]",
"tags": [
"Vendor Advisory",
"Mailing List"
]
},
{
"url": "http://www.openwall.com/lists/oss-security/2026/06/29/25",
"source": "af854a3a-2127-422b-91ae-364da2661108",
"tags": [
"Third Party Advisory"
]
}
]
}