CVE-2026-59084
Full vulnerability record from the local CVENow database.
Description
Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
Severity
CRITICAL
CVSS score
9.1
(v3.1)
Vulnerability status
Analyzed
Source identifier
Published
2026-07-14 09:16:41.607000
Last modified
2026-10-24 21:10:00.130000
View original CVE JSON
{
"id": "CVE-2026-59084",
"sourceIdentifier": "[email protected]",
"published": "2026-07-14T09:16:41.607",
"lastModified": "2026-10-24T21:10:00.130",
"vulnStatus": "Analyzed",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected.\n\nUsers are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue."
},
{
"lang": "es",
"value": "vulnerabilidad de Documentación Técnica Insuficiente en Apache Tomcat ya que los requisitos para configurar de forma segura el EncryptInterceptor no estaban claramente documentados.\n\nEste problema afecta a Apache Tomcat: desde 11.0.0-M1 hasta 11.0.23, desde 10.1.0-M1 hasta 10.1.56, desde 9.0.13 hasta 9.0.119, desde 8.5.38 hasta 8.5.100, desde 7.0.100 hasta 7.0.109. Otras versiones que han llegado al fin de su soporte también pueden verse afectadas.\n\nSe recomienda a los usuarios actualizar a la versión 11.0.24, 10.1.57 o 9.0.120 que solucionan el problema."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "Apache Software Foundation",
"product": "Apache Tomcat",
"defaultStatus": "unaffected",
"versions": [
{
"version": "11.0.0-M1",
"lessThanOrEqual": "11.0.23",
"versionType": "semver",
"status": "affected"
},
{
"version": "10.1.0-M1",
"lessThanOrEqual": "10.1.56",
"versionType": "semver",
"status": "affected"
},
{
"version": "9.0.13",
"lessThanOrEqual": "9.0.119",
"versionType": "semver",
"status": "affected"
},
{
"version": "8.5.38",
"lessThanOrEqual": "8.5.100",
"versionType": "semver",
"status": "affected"
},
{
"version": "7.0.100",
"lessThanOrEqual": "7.0.109",
"versionType": "semver",
"status": "affected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV31": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N",
"baseScore": 9.1,
"baseSeverity": "CRITICAL",
"attackVector": "NETWORK",
"attackComplexity": "LOW",
"privilegesRequired": "NONE",
"userInteraction": "NONE",
"scope": "UNCHANGED",
"confidentialityImpact": "HIGH",
"integrityImpact": "HIGH",
"availabilityImpact": "NONE"
},
"exploitabilityScore": 3.9,
"impactScore": 5.2
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-07-14T13:51:48.818351Z",
"id": "CVE-2026-59084",
"options": [
{
"exploitation": "none"
},
{
"automatable": "yes"
},
{
"technicalImpact": "total"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-1059"
}
]
}
],
"configurations": [
{
"nodes": [
{
"operator": "OR",
"negate": false,
"cpeMatch": [
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"versionStartIncluding": "7.0.100",
"versionEndIncluding": "7.0.109",
"matchCriteriaId": "21FCAD61-9B9D-4780-9EE2-2F28B3F951F5"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"versionStartIncluding": "8.5.38",
"versionEndIncluding": "8.5.100",
"matchCriteriaId": "769FDDAB-B636-43A6-BB06-CCE9185D5EA6"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"versionStartIncluding": "9.0.13",
"versionEndIncluding": "9.0.119",
"matchCriteriaId": "A332E23F-9A0B-41C6-B00D-8E92BF206791"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"versionStartIncluding": "10.1.0",
"versionEndIncluding": "10.1.56",
"matchCriteriaId": "1B3DEC2A-7E4A-4851-8466-AFCC4B249748"
},
{
"vulnerable": true,
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"versionStartIncluding": "11.0.0",
"versionEndIncluding": "11.0.23",
"matchCriteriaId": "30943912-13A4-40D8-A9E3-9DE3C0008258"
}
]
}
]
}
],
"references": [
{
"url": "https://lists.apache.org/thread/7w9746ootcxo0gvx26xjpw80l31f1qw7",
"source": "[email protected]",
"tags": [
"Mitigation",
"Vendor Advisory"
]
},
{
"url": "http://www.openwall.com/lists/oss-security/2026/07/14/8",
"source": "af854a3a-2127-422b-91ae-364da2661108",
"tags": [
"Mailing List",
"Third Party Advisory"
]
}
]
}