CVE-2026-75857
Full vulnerability record from the local CVENow database.
Description
CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.
View original CVE JSON
{
"id": "CVE-2026-75857",
"sourceIdentifier": "[email protected]",
"published": "2026-08-18T16:18:21.520",
"lastModified": "2026-10-29T21:17:33.107",
"vulnStatus": "Deferred",
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release."
},
{
"lang": "es",
"value": "Las versiones de CodeWhale >= 0.8.41 y < 0.8.64 contienen una vulnerabilidad en la herramienta exec_shell_interact (alias exec_interact), cuyo approval_requirement devuelve ApprovalRequirement::Auto. Esto anula la aprobación predeterminada ’Required’ para herramientas de ejecución de código, por lo que la entrada estándar (stdin) controlada por LLM se escribe en un shell interactivo de larga duración ya aprobado (por ejemplo, un REPL de python3 -i, MySQL, ssh o una sesión de sudo -i) sin ninguna solicitud de aprobación. Un atacante que puede inyectar instrucciones a través de contenido no confiable que el agente ingiere (una página obtenida, un resultado de MCP o un archivo de repositorio) puede hacer que los comandos se ejecuten con el nivel de privilegio de ese proceso aprobado. Corregido en 0.8.64."
}
],
"affected": [
{
"source": "[email protected]",
"affectedData": [
{
"vendor": "Hmbown",
"product": "CodeWhale",
"defaultStatus": "unaffected",
"packageURL": "pkg:cargo/deepseek-tui",
"versions": [
{
"version": "0.3.10",
"lessThanOrEqual": "0.8.41",
"versionType": "semver",
"status": "affected"
}
]
},
{
"vendor": "Hmbown",
"product": "CodeWhale",
"defaultStatus": "unaffected",
"packageURL": "pkg:npm/deepseek-tui",
"versions": [
{
"version": "0.3.10",
"lessThan": "0.8.41",
"versionType": "semver",
"status": "affected"
},
{
"version": "0.8.41",
"versionType": "semver",
"status": "unaffected"
}
]
},
{
"vendor": "Hmbown",
"product": "CodeWhale",
"defaultStatus": "unaffected",
"packageURL": "pkg:cargo/codewhale-tui",
"versions": [
{
"version": "0.8.41",
"lessThan": "0.8.64",
"versionType": "semver",
"status": "affected"
},
{
"version": "0.8.64",
"versionType": "semver",
"status": "unaffected"
}
]
},
{
"vendor": "Hmbown",
"product": "CodeWhale",
"defaultStatus": "unaffected",
"packageURL": "pkg:npm/codewhale",
"versions": [
{
"version": "0.8.41",
"lessThan": "0.8.64",
"versionType": "semver",
"status": "affected"
},
{
"version": "0.8.64",
"versionType": "semver",
"status": "unaffected"
}
]
}
]
}
],
"metrics": {
"cvssMetricV40": [
{
"source": "[email protected]",
"type": "Secondary",
"cvssData": {
"version": "4.0",
"vectorString": "CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X",
"baseScore": 7.3,
"baseSeverity": "HIGH",
"attackVector": "LOCAL",
"attackComplexity": "HIGH",
"attackRequirements": "PRESENT",
"privilegesRequired": "NONE",
"userInteraction": "PASSIVE",
"vulnConfidentialityImpact": "HIGH",
"vulnIntegrityImpact": "HIGH",
"vulnAvailabilityImpact": "HIGH",
"subConfidentialityImpact": "NONE",
"subIntegrityImpact": "NONE",
"subAvailabilityImpact": "NONE",
"exploitMaturity": "NOT_DEFINED",
"confidentialityRequirement": "NOT_DEFINED",
"integrityRequirement": "NOT_DEFINED",
"availabilityRequirement": "NOT_DEFINED",
"modifiedAttackVector": "NOT_DEFINED",
"modifiedAttackComplexity": "NOT_DEFINED",
"modifiedAttackRequirements": "NOT_DEFINED",
"modifiedPrivilegesRequired": "NOT_DEFINED",
"modifiedUserInteraction": "NOT_DEFINED",
"modifiedVulnConfidentialityImpact": "NOT_DEFINED",
"modifiedVulnIntegrityImpact": "NOT_DEFINED",
"modifiedVulnAvailabilityImpact": "NOT_DEFINED",
"modifiedSubConfidentialityImpact": "NOT_DEFINED",
"modifiedSubIntegrityImpact": "NOT_DEFINED",
"modifiedSubAvailabilityImpact": "NOT_DEFINED",
"Safety": "NOT_DEFINED",
"Automatable": "NOT_DEFINED",
"Recovery": "NOT_DEFINED",
"valueDensity": "NOT_DEFINED",
"vulnerabilityResponseEffort": "NOT_DEFINED",
"providerUrgency": "NOT_DEFINED"
}
}
],
"cvssMetricV31": [
{
"source": "[email protected]",
"type": "Secondary",
"cvssData": {
"version": "3.1",
"vectorString": "CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H",
"baseScore": 7.0,
"baseSeverity": "HIGH",
"attackVector": "LOCAL",
"attackComplexity": "HIGH",
"privilegesRequired": "NONE",
"userInteraction": "REQUIRED",
"scope": "UNCHANGED",
"confidentialityImpact": "HIGH",
"integrityImpact": "HIGH",
"availabilityImpact": "HIGH"
},
"exploitabilityScore": 1.0,
"impactScore": 5.9
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"timestamp": "2026-08-19T14:37:17.470789Z",
"id": "CVE-2026-75857",
"options": [
{
"exploitation": "poc"
},
{
"automatable": "no"
},
{
"technicalImpact": "total"
}
],
"role": "CISA Coordinator",
"version": "2.0.3"
}
}
]
},
"weaknesses": [
{
"source": "[email protected]",
"type": "Secondary",
"description": [
{
"lang": "en",
"value": "CWE-269"
}
]
}
],
"references": [
{
"url": "https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381",
"source": "[email protected]"
},
{
"url": "https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r",
"source": "[email protected]"
},
{
"url": "https://www.vulncheck.com/advisories/codewhale-before-privilege-escalation-via-exec-shell-interact",
"source": "[email protected]"
},
{
"url": "https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r",
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0"
}
]
}